Return to the Australian Native Plants Forum | Post a Follow-Up

 o
Leptospermum morrisonii 'Burgundy'

Posted by thefof NSW Aust (My Page) on
Fri, Aug 29, 14 at 22:16

Guys
A quick question.
I have had this in for about 4 years and it has never flowered. I did cut it back a bit about a year ago before spring.
My neighbours also put one in a couple of years ago and their's, likewise, refuses to flower.
Both plants are in full sun
Any suggestions?

TIA

Fof


Follow-Up Postings:

 o
RE: Leptospermum morrisonii 'Burgundy'

I've no suggestions, thefof but I also planted one just on 12 months ago, top of a slope, facing north-east, exposed to winds and the in the distance the Coral Sea. Lovely looking plant, nice burgundy shade to the foliage but also, no flowers. Am hoping for a bit of a show this year but no sign of anything yet. Will let you know if and when I see a bud or two.
B.


 o
RE: Leptospermum morrisonii 'Burgundy'

Hi funnelweb
I am confused about this plant. Went to the nursery where I know both plants (mine and neighbours) came from, with a cutting.
They claimed they have never had it, but they did show me a 'hybrid' labelled L. morrisonii 'Burgundy' which had leaves many times larger but the same colour. I pointed out it couldn't be called L. morrisonii if it was a hybrid and wondered which was actually correctly labelled. They reckon mine is!
I wonder which you have? I will get a picture at the weekend of the 2 together.

Fof


 o
RE: Leptospermum morrisonii 'Burgundy'

My label from 'Touch of Class plants' just says it's Lepto. morrisonii, no mention of burgundy. Says it's very hardy, grows 1.5 to 2m by 1.5 to 5 wide (I think that's a mistake!). The picture on the label shows a pure white flower with green centre and green leaves, no hint of burgundy. The picture is obviously incorrect as the leaves on my plant are definitely burgundy and are certainly on the small side.
I just scanned the label and will post it:
PS. I'll go take a pic of my plant tomorrow, too dark out now.
B.


the picture on the label is not the plant in the ground; it shows a clear white flower with greeny calyxs and leaves, whereas the leaves of the plant are burgundy coloured. I'm confident the label is correctly named though. It's dark out now, so I'll go take a photo tomorrow and post it.


 o
RE: Leptospermum morrisonii 'Burgundy'

Arr the bit after the 'B' above should have been deleted. Anyway, I took a photo of my L. morrisonii today. While there's no flowers it certainly has little if any resemblance to the label above. No wonder folks are confused:


 o
RE: Leptospermum morrisonii 'Burgundy'

Went out to the nursery yesterday and had a word with one of the guys there. Not the one I spoke to previously. He again showed me the one they had but with the additional information that they had only just emerged from the tunnels after a regime of regular water and osmacote.
He then took me out the back to see one they had planted out about 5 yrs ago, when they first appeared on the market. A dead ringer for what I have and it had only had a couple of flowers last year, for the first time.
Here is a pic showing the difference in the foliage. The latest is on the left and my original on the right.
At a guess, looking at your pic, funnelweb, I would say your is the large leaf one which appears to be closer to L. morrisonii than mine. Going from PlantNET, L.m foliage is 15-35 mm long, 2-8 mm wide.
I wonder what I have?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Australian Native Plants Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here